Current Site Status

Temporary solutions often become permanent problems.

—Craig Bruce

Find a problem? Let me know.

WarningA log of known issues and “undocumented features.”

I’m using this page to keep track of any site issues.

Current Status: All is well.

Years

2016

February 3, 2016: There was a problem with the navigation menu. All is better now.

2015

August 27, 2015: All better now. Looks like it was an image-optimization issue after all. Kraken really helped.

August 22, 2015: The site is loading slower than normal. Most likely, this stems from possible plug-in conflicts with WordPress 4.3. Resolution pending.

March 18, 2015: Date issue for events is fixed; they are now showing up with the event date, not the date on which I published the event.

January 23, 2015: Tab issue appears to finally be fixed. Superfluous carriages kept appearing, driving me crazy.

2014

December 26, 2014: The sites for my third and fourth books (www.thenewsmall.com and www.theageoftheplatform.com) now redirect to their corresponding pages on this site.

November 27, 2014: Minor tweaks, including fixed links to some of the book pages.

November 3, 2014: I had a few things miscoded like the The Next Wave of Technologies book page related posts. I also fixed a few misplaced carriages. These little buggers are pesky. They keep reappearing. Divi knows that this is an issue and evidently is working on a fix.

October 31, 2014: Event videos have been fixed. There was some type of strange Vimeo short code conflict with either a plugin or the theme. I had to replace all videos. Thank heavens for TextExpander.

October 22, 2014: New site is live. There were a few minor images issues but all seems to be well. There are a few minor formatting issues that will be fixed in the next day or so.

September10, 2014: Posts from www.theageoftheplatform.com have now been ported over. There may be a few lingering image and URL issues. Construction

September 3, 2014: Site search was broken; it’s fixed now.

June 21, 2014: Navigation menu issue appears to be solved. This one was very tricky and probably plugin-related.

June 9, 2014: Navigation menu has been acting strange; sidebar is not appearing on the side. Looking into this.

February 6, 2014: I rolled back the site a few weeks to try to isolate the issue. Everything appears to be back to normal. Posts were briefly deleted.

February 3, 2014: There are some bizarre CSS issues, perhaps stemming from a plug-in. The iPad version is also broken. It might be an iOS 7.0.4 issue. I’m on it.

2013

November 18, 2013: Site home page was missing; it was defaulting to a list of blog posts. Probably a WordPress issue. Restored.

June 26, 2013, 6:00 pm: All better.

June 26, 2013, 12:00 pm: Some YouTube videos in posts aren’t appearing correctly. There’s an issue with the responsive video plug-in. I’m working with my developer on the issue. There’s also an issue with the mobile site because of a WP Engine/Zerigo issue.